Welcome to ExamTopics
ExamTopics Logo
- Expert Verified, Online, Free.

Unlimited Access

Get Unlimited Contributor Access to the all ExamTopics Exams!
Take advantage of PDF Files for 1000+ Exams along with community discussions and pass IT Certification Exams Easily.

Exam AZ-101 topic 3 question 12 discussion

Actual exam question from Microsoft's AZ-101
Question #: 12
Topic #: 3
[All AZ-101 Questions]

You have an Azure subscription that contains a virtual network named VNet1. VNet 1 has two subnets named Subnet1 and Subnet2. VNet1 is in the West Europe
Azure region.
The subscription contains the virtual machines in the following table.

You need to deploy an application gateway named AppGW1 to VNet1.
What should you do first?

  • A. Add a service endpoint.
  • B. Add a virtual network.
  • C. Move VM3 to Subnet1.
  • D. Stop VM1 and VM2.
Show Suggested Answer Hide Answer
Suggested Answer: D 🗳️
If you have an existing virtual network, either select an existing empty subnet or create a new subnet in your existing virtual network solely for use by the application gateway.
Verify that you have a working virtual network with a valid subnet. Make sure that no virtual machines or cloud deployments are using the subnet. The application gateway must be by itself in a virtual network subnet.
https://social.msdn.microsoft.com/Forums/azure/en-US/b09367f9-5d01-4cda-9127-b7a506a0a151/cant-create-application-gateway? forum=WAVirtualMachinesVirtualNetwork https://docs.microsoft.com/en-us/azure/application-gateway/application-gateway-create-gateway


Chosen Answer:
This is a voting comment (?) , you can switch to a simple comment.
Switch to a voting comment New
9 months, 2 weeks ago
I don't get it, why need to move VM3 to subnet1?
upvoted 1 times
3 years, 3 months ago
It's clear that C is a lot better answer than D.
upvoted 2 times
3 years, 9 months ago
I think option C "Move VM3 to Subnet1" is only valid. Tested this movement (inside assigned NIC in section IPConfiguration, there is an option to change subnet, which restarted VM). After restart VM had new private IP from different subnet. I also tried to stop VM in subnet, where only this VM was assigned. Then I tried to create new AppGtw to this subnet and portal did not give me the option, selected subnet was not possible to use. Even if VM was stopped, it still had its privateID (public was released) what was probably the reason, why this subnet is not usable for AppGtw.
upvoted 3 times
3 years, 10 months ago
Why solution "C" is not valid?
upvoted 1 times
Community vote distribution
A (35%)
C (25%)
B (20%)
Most Voted
A voting comment increases the vote count for the chosen answer by one.

Upvoting a comment with a selected answer will also increase the vote count towards that answer by one. So if you see a comment that you already agree with, you can upvote it instead of posting a new comment.

Loading ...