Click the Exhibit button.
[edit]
user@PE-1# run show l2 circuit connections
Layer-2 Circuit Connections:
Legend for connection status (St)
EI - - encapsulation invalid NP - - interface h/w not present
MM - - mtu mismatch Dn - - down
EM - - encapsulation mismatch VC-Dn - -
Virtual circuit Down -
CM - - control-word mismatch Up - -
operational
VM - - vlan id mismatch CF - - Call
admission control failure
OL - - no outgoing label IB - - TDM
incompatible bitrare
NC - - intf encaps not CCC/TCC TM - - TDM
misconfiguration
BK - - Backup Connection ST - - Standby
Connection -
CB - - rcvd cell-bundle size bad SP - - Static
Pseudowire -
LD - - local site signaled down RS - - remote
site standby
RD - - remote site signaled down XX - - unknown
Legend for interface status -
Up - - operational -
Dn - - down -
Neighbor: 4.4.4.4 -
Interface Type St Time
last up #Up trans
ge-0/0/1.512 (vc 1) rmt OL
[edit]
user@PE-1# show protocols ldp
interface ge-0/0/2.0;
[edit]
user@PE-1# show protocols l2circuit
neighbor 4.4.4.4 {
interface ge-0/0/1.512 {
virtual-circuit-id 1
}
}
[edit]
user@PE-1# show interfaces ge-0/0/1
vlan-tagging;
encapsulation vlan-ccc;
unit 512 {
encapsulation vlan-ccc;
vlan-id 512;
}
[edit]
uxer@P-1 # show protocols ldp
interface all;
[edit]
user@P-2# show protocols ldp
interface all;
[edit]
user@PE-2# run show l2circuit connections
Layer-2 Circuit Connections:
Legend For connection status (St)
EI - - encapsulation invalid NP - - interface h/w not present
MM - - mtu mismatch Dn - - down
EM - - encapsulation mismatch VC-Dn - -
Virtual circuit Down -
CM - - control-word mismatch Up - -
operational
VM - - vlan id mismatch CF - - Call
admission control failure
OL - - no outgoing label IB - - TDM
incompatible bitrate
NC - - intf encaps not CCC/TCC TM - - TDM
misconfiguration
BK - - Backup Connection ST - - Standby
Connection -
CB - - rcvd cell-bundle size bad SP - - Static
Psewdowire -
LD - - Local site signaled down RS - - remote
site standby
RD - - remote site signaled down XX - - unknown
Legend for interface status -
UP - - operational -
DN - - down -
Neighbor: 1.1.1.1 -
Interface Type St Time
last up #Up trans
ge-0/0/1.512 (vc 1) rmt OL
[edit]
user@PE-2# show protocols ldp
interface ge-0/0/2.0;
[edit]
user@PE-2# show protocols l2circuit
neighbor 1.1.1.1 {
interface ge-0/0/1.512 {
virtual-circuit-id 1;
}
}
[edit]
user@PE-2# show interfaces ge-0/0/1
vlan-tagging;
encapsulation vlan-ccc;
unit 512 {
encapsulation vlan-ccc;
vlan-id 512;
}
Referring to the exhibit, you have configured an L2 circuit that connects Site-1 and Site-2, but the L2 circuit is not functioning. The topology in this scenario is shown below.
Site-1 > PE-1 > P-1 > P-2 > PE-2 Site-2
Which action will allow communication between Site-1 and Site-2?
Correct Answer:
C
🗳️
LDP is required as the signaling protocol for Layer 2 circuits. You must include the loopback address in LDP. We enable ldp on the loopback interfaces.
Incorrect Answers:
A: The virtual circuit identifer is correctly set to 1 both at PE-1 and PE-2.
References:
https://www.juniper.net/techpubs/en_US/junos12.3/topics/example/layer-two-circuits-ethernet-configuring-detailed-solutions.html
Which command will match communities 101:111, 111:1, and 999:1111?
Correct Answer:
D
🗳️
Period (.)A wildcard character that matches any single digit in an AS number.
+ stands for one or more repetitions of term.
? stands for zero or one repetition of term.
References:
http://www.juniper.net/documentation/en_US/junos15.1/topics/usage-guidelines/policy-defining-bgp-communities-and-extended-communities-for-use- in-routing-policy-match-conditions.html#id-10243437
Click the Exhibit button.
[edit]
user@PE-1# show protocols
rsvp {
interface all;
}
mpls {
label-switched-path p1 {
from 1.1.1.1;
to 4.4.4.4;
no cspf;
}
interface all;
}
bgp {
group Int {
type Internal;
local-address 1.1.1.1;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
neighbor 2.2.2.2;
neighbor 3.3.3.3;
neighbor 4.4.4.4;
}
}
ospf {
area 0.0.0.0 {
interface ge-0/0/2.0;
interf lo0.0;
}
}
[edit]
user@p-1# show protocols
mpls {
interface all;
}
ospf {
area 0.0.0.0 {
interface ge-0/0/1.0;
interface ge-0/0/2.0;
interface ge-1o0.0;
}
}
[edit]
user@p-2# show protocols
mpls {
interface all;
}
ospf {
area 0.0.0.0 {
interface ge-0/0/1.0;
interface ge-0/0/2.0;
interface ge-lo0.0;
}
}
[edit]
user@p-2# show protocols
rsvr {
interface all;
}
mpls {
label-switched-path p2 {
from 4.4.4.4;
to 1.1.1.1;
no-ospf
}
interface all;
}
bgp {
group INT {
type internal;
local-address 4.4.4.4,
family inet {
unicast;
neighbor 2.2.2.2;
neighbor 3.3.3.3;
neighbor 1.1.1.1;
}
}
ospf {
area 0.0.0.0 {
interface ge-0/0/2.0;
interface 1o0;
}
}
Referring to the exhibit, you have configured an L3VPN that connects Site-1 and Site-2 together, but the BGP routes are being hidden on the PE routers. The topology in this scenario is shown below.
Site-1 > PE-1 > P-1 > P-2 > PE-2 > Site-2
Which two acttions would allow communication Site-1 and Site-2? (Choose two.)
Correct Answer:
CD
🗳️
Hidden routes usually means that routes were not labeled properly. You should enable RSVP or LDP on all routers. RSVP is already configured on PE-1 so we only need to configure it on P-1 and P-2.
References:
https://packetcorner.wordpress.com/2013/01/30/mpls-l3vpn/
A layer 2 circuit (RFC 4447) is established between two PE routers to provide connectivity between two customer sites.
Which two statements related to this deployment are true?
Correct Answer:
BD
🗳️
Junos OS substantially supports t RFC 4447, Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP).
Martini uses directed LDP to signal the VPN label between the PE devices, Kompella uses BGP to signal the VPN label between the PE devices.
References:
https://www.juniper.net/documentation/en_US/junos15.1/topics/reference/standards/layer-2-circuit.html